同网段内配置基于全局地址池的DHCP服务器示例

组网需求

华为交换机配置基于全局地址池的DHCP服务器

如图1所示,某企业有两个处于同一网络内的办公室,为了节省资源,两个办公室内的主机由SwitchA作为DHCP服务器统一分配IP地址。

办公室1所属的网段为10.1.1.0/25,主机都加入VLAN10,办公室1的主机只使用服务,不使用NetB服务,地址租期为10天;办公室2所属的网段为10.1.1.128/25,主机都加入VLAN20,办公室2的主机使用DNS服务和NetBIOS服务,地址租期为2天。

在SwitchA上配置全局地址池,并采取动态地址分配方式为两个办公室的主机分配IP地址。

图1 配置基于全局地址池的DHCP服务器组网图

 

配置思路

DHCP服务器的配置思路如下:

  1. 在SwitchA上创建两个全局地址池,并配置各自的地址池相关属性,实现根据不同需求,为办公室1和办公室2动态分配地址。
  2. 在SwitchA上配置VLANIF接口下本地DHCP服务器的地址分配方式,实现DHCP服务器从全局地址池中给客户端分配IP地址。

操作步骤

启动DHCP服务 <HUAWEI> system-view
[HUAWEI] sysname SwitchA
[SwitchA] dhcp enable
  1. 创建地址池并配置相关属性
  2. # 配置IP地址池1的属性(地址池范围、DNS地址、出口网关、不参与分配的地址和地址池租期)。
[SwitchA] ip pool 1
[SwitchA-ip-pool-1] network 10.1.1.0 mask 255.255.255.128
[SwitchA-ip-pool-1] dns-list 10.1.1.2
[SwitchA-ip-pool-1] gateway-list 10.1.1.1
[SwitchA-ip-pool-1] excluded-ip-address 10.1.1.2
[SwitchA-ip-pool-1] excluded-ip-address 10.1.1.4
[SwitchA-ip-pool-1] lease day 10
[SwitchA-ip-pool-1] quit
  1. # 配置IP地址池2的属性(地址池范围、DNS地址、出口网关、NetBIOS地址和地址池租期)。
[SwitchA] ip pool 2
[SwitchA-ip-pool-2] network 10.1.1.128 mask 255.255.255.128
[SwitchA-ip-pool-2] dns-list 10.1.1.2
[SwitchA-ip-pool-2] nbns-list 10.1.1.4
[SwitchA-ip-pool-2] gateway-list 10.1.1.129
[SwitchA-ip-pool-2] lease day 2
[SwitchA-ip-pool-2] quit
  1. 配置VLANIF接口下地址分配方式
  2. # 配置接口GigabitEthernet1/0/1和GigabitEthernet1/0/2分别加入相应的VLAN。
[SwitchA] vlan batch 10 20
[SwitchA] interface gigabitethernet 1/0/1
[SwitchA-GigabitEthernet1/0/1] port link-type hybrid
[SwitchA-GigabitEthernet1/0/1] port hybrid pvid vlan 10
[SwitchA-GigabitEthernet1/0/1] port hybrid untagged vlan 10
[SwitchA-GigabitEthernet1/0/1] quit
[SwitchA] interface gigabitethernet 1/0/2
[SwitchA-GigabitEthernet1/0/2] port link-type hybrid
[SwitchA-GigabitEthernet1/0/2] port hybrid pvid vlan 20
[SwitchA-GigabitEthernet1/0/2] port hybrid untagged vlan 20
[SwitchA-GigabitEthernet1/0/2] quit
  1. # 配置VLANIF10接口下的客户端从全局地址池中获取IP地址。
[SwitchA] interface vlanif 10
[SwitchA-Vlanif10] ip address 10.1.1.1 255.255.255.128
[SwitchA-Vlanif10] dhcp select global
[SwitchA-Vlanif10] quit
  1. # 配置VLANIF20接口下的客户端从全局地址池中获取IP地址。
[SwitchA] interface vlanif 20
[SwitchA-Vlanif20] ip address 10.1.1.129 255.255.255.128
[SwitchA-Vlanif20] dhcp select global
[SwitchA-Vlanif20] quit
  1. 验证配置结果
  2. 在SwitchA上使用display ip pool命令用来查看IP地址池配置情况。
[SwitchA] display ip pool
 -----------------------------------------------------------------------
 Pool-name : 1
 Pool-No : 0
 Lease : 10 Days 0 Hours 0 Minutes 
 Position : Local Status : Unlocked
 Gateway-0 : 10.1.1.1
 Network : 10.1.1.0 
 Mask : 255.255.255.128
 VPN instance : --
 Address Statistic: Total :125 Used :2 
 Idle :121 Expired :0 
 Conflict :0 Disable :2 
 
 -----------------------------------------------------------------------
 Pool-name : 2
 Pool-No : 1
 Lease : 2 Days 0 Hours 0 Minutes 
 Position : Local Status : Unlocked
 Gateway-0 : 10.1.1.129
 Network : 10.1.1.128 
 Mask : 255.255.255.128
 VPN instance : --
 Address Statistic: Total :125 Used :4 
 Idle :121 Expired :0 
 Conflict :0 Disable :0 
 
 
 IP address Statistic
 Total :250
 Used :6 Idle :242
 Expired :0 Conflict :0 Disable :2

配置文件

SwitchA的配置文件

#
sysname SwitchA
#
vlan batch 10 20
#
dhcp enable
#
ip pool 1
 gateway-list 10.1.1.1
 network 10.1.1.0 mask 255.255.255.128
 excluded-ip-address 10.1.1.2
 excluded-ip-address 10.1.1.4
 lease day 10 hour 0 minute 0
 dns-list 10.1.1.2
#
ip pool 2
 gateway-list 10.1.1.129
 network 10.1.1.128 mask 255.255.255.128
 lease day 2 hour 0 minute 0
 dns-list 10.1.1.2
 nbns-list 10.1.1.4
#
interface Vlanif10
 ip address 10.1.1.1 255.255.255.128
 dhcp select global 
#
interface Vlanif20
 ip address 10.1.1.129 255.255.255.128
 dhcp select global 
#
interface GigabitEthernet1/0/1
 port link-type hybrid
 port hybrid pvid vlan 10
 port hybrid untagged vlan 10 
#
interface GigabitEthernet1/0/2
 port link-type hybrid
 port hybrid pvid vlan 20
 port hybrid untagged vlan 20 
#
return
胜象大百科